SVN hooks not working at all during commit

I'm trying to use svn hooks in my repo, but it doesn't seem to work fine. In the following are the steps I tried to approach:    checked out from a remote server: remote server    since the checked out repo doesn't have any content, I created a new svn repo locally and copied over everything including the /hooks folder to my checked out repo.    I created an empty file in the checked out repo and added a line of text. Then svn add this file.    modified the hooks/pre-commit.tmpl file and now it looks like:    #!/bin/sh  echo "start pre commit test" >> *my checked out repo dir*/CommitMessage  exit 0  add execute permit to all users and copy the pre-commit.tmpl to pre-commit    in the checked out repo I committed the changes using: svn commit -m "dumb change"    Now from here I should see a CommitMessage file and with the text "start pre commit test" in it right? Somehow I don't see it anywhere.    If I run ./hooks/pre-commit, it works fine. I ran env - svn commit -m "dumb change" 1234 as well, but still nothing. Seems like when committing, it doesn't call pre-commit at all. Maybe I understood wrong about how the hooks work?

1-1 of 1

Reply to this discussion

You cannot edit posts or make replies: You should be logged in before you can post.