Missing Option: Disable Auto-Refresh

gdgib
gdgib
There used to be an option in older versions of SmartSVN, to disable the working copy refresh on SmartSVN window activation. It is missing in 7.5.3 and 7.5.4, and I think earlier 7.5.x releases. Given that the option is still in the website documentation: [url]http://smartsvn.com/documentation/preferences.refresh[/url], am I missing something? This is probably a deal-breaker, as it causes SmartSVN to waste an INCREDIBLE number of processor and hard drive resources. Please let me know if there's anything I can do to help, or explain. I'm happy to edit options files or whatever it takes. -Greg

Last updated

Mand
Mand
Hi there, You can change this in Transactions> Settings > Refresh. Does that do what you want?
gdgib
gdgib
Perhaps I'm being dense, but those settings affect the transactions window only correct? I'm looking to disable auto-refresh of my working copy, that is to say the project window. I do not care about transactions window refresh policy. Please refer to the manual link that I posted earlier. The options listed on that page used to control refresh of the project/workingcopy, but they no longer exist in the SmartSVN 7.5.x versions.
gdgib
gdgib
What's more, I notice that none of the options in that window mention refreshing when the application regains focus. That is what I'm trying to prevent. As a result I'm pretty sure options are irrelevant to working copy refreshes. And even if they were relevant, they do not allow me to change what I need to. In summary, I again refer you to the manual link I posted earlier and the discrepancy between the contents therein and the SmartSVN 7.5.4 GUI, which precisely captures the feature regression that is frustrating me.
Mand
Mand
Apologies, I misunderstood what you were looking for. The website documentation is a little out of date (we're working on that right now). The pdf version is up to date though (you can find it [URL="http://smartsvn.com/get?f=smartsvn%2Fsmartsvn-manual.pdf"]here[/URL]). In any case, the feature you want is missing in 7.5.x versions, I've raised a bug to get this back in the next version of SmartSVN (SU-17636).
gdgib
gdgib
Actually having the old documentation proved helpful in confirming I wasn't crazy to miss this. Honestly can't say I've ever needed to read it, SmartSVN is pretty intuitive. Anyway, I appreciate your raising that bug, I'm eagerly awaiting the next version now. Thank you very much.

1-6 of 6

Reply to this discussion

You cannot edit posts or make replies: You should be logged in before you can post.

Post a reply
3802 views