Global Ignore Confusion...

imnickb
imnickb
The title says it all, I'm confused about how to get Global Ignore working right.    I'd like to add a directory and it's content as well as a couple of other miscellaneous files to a Global Ignore list. Everyone on the team is using SmartSVN and I'd like the files to be ignored on everyone's build. I've read the documentation and it looks like I have to options: "Use from SVN Config file" and "Use the following patterns."    I tried "Use the following patterns" and I don't see that it's working. How would I know that it's working? I still see files I'd like to ignore in the Directories pane and the Files pane. I'm wondering if I didn't use the proper syntax in the patterns box? What is the proper syntax? I would like to ignore this directory as well as all of its contents:    /Develop/SleepyTime/Library    I tried entering it in the box just like that and it doesn't seem to be working. I also tried leaving off /Develop/SleepyTime/ since that's the root directory it shows in the top of the settings box.    Once I get it working, do I need to check it in somehow to make it "stick" fir everyone that uses the repository?    I can try using the SVN config file but I don't know where that's located for SmartSVN and what syntax I need to use for that either. Do I need to give that config file to everyone so they're ignoring the same stuff? Sorry for the 20 questions but I'm stuck.    Thanks!

Last updated

imnickb
imnickb
UPDATE... I was able to add two directories and two files to the ignore list using "Use the following patterns."  This is what I put in the box:  Library* Temp* -tk2d.asset -tk2d.asset.meta  I had to quit and restart to see the changes...  I have one last question still however. I originally thought that global meant that everybody using the repository would be set to ignore the files but I don't think that's the case. Is there anyway to somehow check in an ignore property into a parent directory or something? Would using the local ignore do that or is it not possible? Do I just need to send an ignore list to the team?  Thanks!

1-2 of 2

Reply to this discussion

You cannot edit posts or make replies: You should be logged in before you can post.