Partial checkout using externals

sbend
sbend
I am actually using TortoiseSVN release 1.8.8 and have a problem checking out externals when doing a sparse checkout (working copy after choosing items). Even though The omit externals check boix is not checked, I never get externals checked out.

Last updated

orbrey
orbrey
Hi, What happens when you try? Also please can you give us a bit of information about how the server is configured and the repositories and externals are arranged?
sbend
sbend
I have a root directory that is configured using tortoisesvn/properties/new/externals to point to a directory in an SVN repository. This property was commited to the svn server. Under this root directory, I have many other directories/subdirectories. I want to partially checkout the root directory, but want also to get the external directory. So I checkout using svncheckout and then I select choose items for selecting the items I am interested in. The check "omit externals" is not checked , then I press OK The checked directories are indeed being copied to the local repository but the externals don't get copied. If I do the same but selecting Fully recursive, the externals get copied.
orbrey
orbrey
That last sentence is making me wonder - the default depth for a checkout should be infinite, so what was the actual command you ran when it failed?
acaron
acaron
Same issue, more info. I'm having the same issue. Here's some more detail. I'm using smartSVN version 8.6 but i'm running into a similar problem with TortoiseSVN. Here's the repo layout repository1 -Folder1 repository 2 -Folder2 (this one has a property/External to repository1::Folder1 at Head) --Subfolder2.1 --(Folder1) should be a sibling of Subfolder2.1 but it's an external. All operation from here are performed on Folder2. -Under TortoiseSVN I update by clicking TortoiseSVN/Update to revision... in the prompt, i set revision to "HEAD revision". As for the Depth section, The "choose items" button wont let me choose externals, so my only chance is through "Fully recursive" drop-down option. Misc "Omit externals" is not checked as stated previously. -Under SmartSVN Modify/Update More.. tells me i already have everything, but it's not including any externals. Modify/Update prompt, i'm selecting Head, Depth: Fully recursive, Advanced: include External. The output simply says "Updated to HEAD" without getting any external. So far, i was only able to retrieve the external by choosing update fully recursive on tortoisesvn only. i was never able to make it work with smartsvn. Thanks for any help :)
orbrey
orbrey
Just going through replicating this now, and when I defined the external (in SmartSVN) a popup showed offering to watch for changes - this is in SmartSVN 8.6.3. Just wondering if you got that option and clicked it, and whether that would make a difference? If you're not sure or didn't click the option perhaps remove the externals definition and then redefine it to see if it pops up again?
acaron
acaron
The initial repo setup was made from TortoiseSVN. The smartSVN client is only trying to checkout repository 2/Folder 2, it's not trying to modify the external that is already set. I followed your suggestion of removing/re-adding manually the external from smartSVN but i didnt saw any popups. Using SmartSVN 8.6.3 as well. I spotted something thought. When i removed/readded the external, svn:externals, the value was marked as modified. The former value was Folder1 svn:://repository1_address while after, the value was svn:://repository1_address Folder1 both params got inverted... i wonder
Harybald
Harybald
I want to partially checkout the root directory, but want also to get the external directory. So I checkout using svncheckout and then I select choose items for selecting the items I am interested in. The check "omit externals" is not checked , then I press OK __________________________________________________ _________ We provide guarantee to pass [url=http://www.learnalanguage.com/learn-norwegian/]learnalanguage - learn norwegian[/url] gmat with online exam training itil [url=http://www.learnalanguage.com/]http://learnalanguage.com/[/url] and you can also get best quality [url=www.rosettastone.com]rosettastone [/url] mcat along with [url=http://polyglotclub.com/]The Polyglot Club[/url] mcat for your guaranteed success
deep_n28
deep_n28
I'm having the same issue.

1-9 of 9

Reply to this discussion

You cannot edit posts or make replies: You should be logged in before you can post.

Post a reply
3115 views