Upgrade from 1.7.4 issue with mod_authz_svn (URGENT)

DareDevil73
DareDevil73
Hi, we are using SubVersion since many years, we survided to several upgrades, but now we stuck upgrading our production environment from 1.7.4. to 1.8.11. After the upgrade, inside the log I found an error message like this: > Failed to load the mod_authz_svn config: Section name 'MyNotWorkingRepository:/Host/' contains non-canonical fspath '/Host/' I googled a lot without finding any useful information! The ACL files were not changed during the upgrade and the strange behavior is that someone works despite to others, similar, that don't work! Here is an excerpt of the working one: [/] administrator = rw supervisor = rw [MyWorkingRepository:/] developer1 = rw developer2 = rw Here is an excerpt of the NOT working one: [groups] developers = developer1, developer2 [/] administrator = rw supervisor = rw [MyWorkingNotRepository:/] developer1 = r developer2 = r developer3 = r developer4 = r [MyWorkingNotRepository:/Client/] developer1 = rw developer2 = rw [MyWorkingNotRepository:/Host/] developer3 = rw developer4 = rw Could you help us or point me to a documentation about ACL parser changes? Thank you very much, Antonio Petricca Edit 1 : SubVersion has hosted on a Windows Server machine.

Last updated

Prasanna_24
Prasanna_24
In the below case , remove ' / ' after the subfolder name. 1) [MyWorkingNotRepository:/Client/] developer1 = rw developer2 = rw [B]It should be :[/B] [[B]MyWorkingNotRepository:/Client[/B]] developer1 = rw developer2 = rw 2) [MyWorkingNotRepository:/Host/] developer3 = rw developer4 = rw It should be: [B][MyWorkingNotRepository:/Host][/B] developer3 = rw developer4 = rw

1-2 of 2

Reply to this discussion

You cannot edit posts or make replies: You should be logged in before you can post.

Post a reply
838 views