Ubuntu / Repository Browser Problem workaround

rvega
rvega
This fix is not working for ubuntu server 11.04 (64bits).  I'm also getting some errors in my logs:  ubersvn.log [22 May 2011 19:34:57] ERROR (?:?) - ERROR: ComponentVersion Name: uberSVN-httpd-lin-64 could not be found [22 May 2011 19:34:57] ERROR (?:?) - No entity found for query  catalina.log May 22, 2011 8:03:21 PM org.apache.catalina.loader.WebappClassLoader clearThreadLocalMap SEVERE: The web application [/ubersvn] created a ThreadLocal with key of type [null] (value [com.sun.faces.util.Util$1@6908af2a]) and a value of type [java.util.HashMap] (value [{com.sun.faces.patternCache={ = }}]) but failed to remove it when the web application was stopped. This is very likely to create a memory leak.  localhost.log May 22, 2011 7:41:35 PM org.apache.catalina.core.StandardContext listenerStop SEVERE: Exception sending context destroyed event to listener instance of class com.wandisco.ubersvn.init.ServerContextListener java.lang.NullPointerException  at com.wandisco.ubersvn.init.ServerContextListener.contextDestroyed(Unknown Source)  at org.apache.catalina.core.StandardContext.listenerStop(StandardContext.java:4174)  at org.apache.catalina.core.StandardContext.stop(StandardContext.java:4778)  at org.apache.catalina.core.ContainerBase.removeChild(ContainerBase.java:924)  at org.apache.catalina.startup.HostConfig.undeployApps(HostConfig.java:1319)  at org.apache.catalina.startup.HostConfig.stop(HostConfig.java:1290)  at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:323)  at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)  at org.apache.catalina.core.ContainerBase.stop(ContainerBase.java:1086)  at org.apache.catalina.core.ContainerBase.stop(ContainerBase.java:1098)  at org.apache.catalina.core.StandardEngine.stop(StandardEngine.java:450)  at org.apache.catalina.core.StandardService.stop(StandardService.java:587)  at org.apache.catalina.core.StandardServer.stop(StandardServer.java:744)  at org.apache.catalina.startup.Catalina.stop(Catalina.java:648)  at org.apache.catalina.startup.Catalina.start(Catalina.java:615)  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)  at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)  at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)  at java.lang.reflect.Method.invoke(Unknown Source)  at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)  at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414) May 22, 2011 7:41:36 PM org.apache.catalina.core.ApplicationContext log INFO: Destroying Spring FrameworkServlet 'sventon'
ianwild
ianwild
Hi Rvega,   Sorry we haven't come up with anything that might help here. The Sventon repository browser is a source of some early problems and ultimate we are planning to replace it with another repository browser. Are you still having problems with this?   Best Wishes,   Ian
rvega
rvega
I can't make repository browser works. However this is a really great tool, congratulations i'm using your tool and it is amazing!
DBCooper
DBCooper
Hey all,  Has anybody found an alternative workaround? I tired the above on a windows box and I am still unable to browser the repository.   Thanks.
DBCooper
DBCooper
Well I solved my issue with browsing the Repository.   My UberSVN install was setup with the port 9890 but after close inspection my repository has port 9880. Why the difference I have no idea. All I had to do was open up that other port on my router and things started working just great.
ron
ron
modification to above details needed for ubuntu 10.04.3    The download location is wrong for sventon -- that only produces a broken .zip file.    Get http://sventon.googlecode.com/files/sventon-2.5.1-bin-svnkit.zip instead.    Other than that, works for me!
Schyfis
Schyfis
I don't suppose there's a fix for Windows as well? My Repository Browser hasn't worked since install. I posted a detailed thread a few days ago, but it doesn't seem to have been approved by moderators. I'm not sure if it's indicative of a larger problem, or if it's safe to continue without the Repository Browser. I guess I'll try posting again.
otrotabi
otrotabi
I hace installed ubersvn in a Ubuntu 10.04 server and so far I have been able to use everything including the browser. Now the problem is that once I created enough repos to fill the first page under the Repositories tab, I can not use the browser or edit the Repositories listed on the second page. I have not downloaded Sventon fix, but I would say that the problemas are not related, because even deleting the Repositories on that page is not working. Everything works fine with the first page Repositories but not with the others. Subversion itself is working fine and I can interact with these repos ok. Any clues ?
otrotabi
otrotabi
Thank you! That will work for now. Regards    José
shripatel
shripatel
I followed every step to upgrade sventon browser from beta .1 to 2.5.1 earlier in sventon browser i was getting list of entries.  now when i try to browse the repository it shows no folders/files in it.  it says 0 entries.  please can some one help ?  very new to these things pl. guide.  Shri.
shripatel
shripatel
Very thankful to you,that you gave an indication to issue very quickly.  but its sad,,that i have to stop using ubersvn, (because it doesnt give facility to use web based svn, we have to use tortoise client with ubersvn.  thanks alot.
diptesh
diptesh
I have recently installed ubersvn WANdisco 2012 - #12.7-0693 SVN - 1.7 on ubuntu 12.04 server.    Features like checkout, repo creation, commit etc are woking fine but when i try to see the diff of files on the web interface i get the following error  "[B cannot be cast to java.lang.String", Will this workaround fix this too ?

1-20 of 20

Reply to this discussion

You cannot edit posts or make replies: You should be logged in before you can post.